Mikroscada

Mikroscada sitesinden
Şuraya atla: kullan, ara

Mikrodev SCADA Yazılımı

Başlangıç[değiştir | kaynağı değiştir]

SCADA Nedir?[değiştir | kaynağı değiştir]

SCADA terimi İngilizce  "Supervisory Control and Data Acquisition”  kelimelerinin ilk harflerinin okunması ile  oluşturulan bir kısaltmadır. Kapsamlı ve bütünleşmiş bir veri tabanlı kontrol ve izleme sistemi olan SCADA ile bir tesise veya işletmeye ait tüm elektronik birimlerin otomatik kontrolü, gözetlenmesi ve sonuçların raporlanması sağlanabilir. Temel olarak SCADA yazılımından izleme, kontrol, veri toplama, verilerin kaydı ve saklanması işlevlerini gerçekleştirmesi beklenmektedir. SCADA sistemleri endüstriyel proseslerde, imalat, üretim, enerji üretimi, imalat ve rafinerilerde sürekli, kesintili, tekrarlayan ya da ayrık modlarda çalışabilir. Altyapı işlemleri, kamu veya özel sektörlerde su arıtma ve terfi merkezlerinde, atık su arıtma, petrol  ve gaz boru hatları, elektrik iletim ve dağıtım, rüzgâr jeneratörleri, sivil savunma siren sistemleri ve büyük  iletişim sistemlerini içerebilir. Tesis binaları, havaalanları, gemiler ve uzay istasyonları da dahil olmak   üzere kamu ve özel tesisleri kapsayabilir. Isıtma ve havalandırma sistemlerinde (HVAC) erişim ve   enerji tüketimini kontrol ve izleme gerekebilir. SCADA sağladığı maksimum fayda, güvenlik ve kolaylık bakımından endüstri tesislerinin en büyük ihtiyaçlarından olmaya devam edecektir.

MikroSCADA[değiştir | kaynağı değiştir]

MikroSCADA geliştirilirken stabilite, kullanım kolaylığı ve görsellik prensipleri ön planda tutulmuştur. MikroSCADA ile sahada bulunan her türlü otomasyon biriminin görsel olarak takip, kontrol ve değerlendirilmesi sağlanabilir.


MikroSCADA’ nın sahip olduğu bazı özellikleri şöyle özetleyebiliriz:

Geniş Görsel Kütüphane

  • Geniş görsel kütüphanesinin yanında, kullanıcıların da kendi SCADA bileşenlerini kolaylıkla hazırlamasına imkan verir.

Paralel Yedekli Çalışma(Redundant Working Mode)

  • Sahadan veriler her iki SCADA sisteminde okunur ve işlenir.
  • Veri kaybı yaşanmaz
  • Haberleşme durum testleri (saha cihazları veya yedek SCADA)

Server/Client Mimari

  • Çoklu çalışma istasyon desteği
  • Çalışma istasyonlarına yetki seviyesi atama

Lisansa Bağlı Etiket Kapasitesi

  • Sınırsız lisans imkanı (Sistem belleği ile sınırlıdır.)
  • Etiket sayısı kadar alarm etiketi tanımlayabilme
  • Etiket sayısı kadar trend tanımlayabilme

İşletim Sistemi Desteği

  • Windows 7/8/10
  • Windows Server 2008/2012/2016
  • Linux (Debian)
  • MacOSX

Güvenlik

  • Etiketlere ve sayfalara 128 farklı erişim yetkisi tanılama
  • Kullanıcılara 128 farklı grup üyeliği atayabilme
  • İşletim sistemi ile entegre güvenlik
  • Haberleşmede katman 7 protokollerinin TLS/SSL versiyonları
  • Yetkilendirme mekanizmasında düz metin şifreler yerine salt eklenmiş SHA256 özetler kullanır

Veri Aktarım

  • SQL uyumlu dışa ve içe veri aktarım imkanı

Alarm

  • Tanımlanmış tüm etiketler için alarm tanımlama imkanı
  • Alarmlar 256 farklı kritiklik seviyesi tanımlayabilme
  • Aktive alarmları ve alarm geçmişini izleme imkanı
  • Tarih ve önem sırasına göre alarm izleme imkanı
  • Alarm listesinden çıktı alma imkanı: Excel,printer,pdf

Veri Kayıt Trend İzleme

  • Tanımlanmış tüm etiketler için log kayıt imkanı
  • Trend tanımlanmış etiketler grafiksel gösterim
  • Trend tanımlanmış etiket verilerinin excel, pdf veya printer çıktısı

Haberleşme

  • Mikrodev PLC,REMOTE IO ve Gateway ürünleri ile mükemmel bağlantı
  • Endüstri standardı çok sayıda protokolle uyum: MODBUS TCP, MODBUS RTU,DNP3,SNMP, IEC-* ,BACNET

Veri Tabanı Desteği

  • PgSQL
  • ORACLE
  • SQLite

Mimari[değiştir | kaynağı değiştir]

Mikrodev SCADA sunucusu intranet ya da internet üzerinden saha cihazlarına bağlanarak bu cihazların gerçek zamanlı izleme ve kontrolünü sağlar. Topladığı verileri etiket, olay ve alarm veri tabanına kaydeder. Aynı zamanda hazırlanmış olan SCADA projesini kullanarak internet üzerinden sunucuya bağlanan kullanıcıların sahadaki cihazları izlemesini ve kontrol etmesini sağlar. MikroSCADA ile tasarlanan ağ ve donanım topolojisine göre çok farklı kombinasyonlar oluşturulabilmekle beraber, temel olarak aşağıdaki şekilde gösterilen mimari kullanılabilir.

SCADA Mimarisi

Editörün Kullanımı[değiştir | kaynağı değiştir]

SCADA projesi Mikroscada Editör programı ile oluşturulur. “Bileşen Yöneticisi” kullanılarak yeni görsel bileşenler oluşturulabilir. Kullanıcı ve grup erişim hakları da “Kullanıcı Yöneticisi” aracılığıyla değiştirilir.

Arayüz[değiştir | kaynağı değiştir]

Editörün sol tarafında bulunan paneller kullanılarak proje dosyaları ve bileşenler kontrol edilir. Ve yine bu panellerin en altında bulunan arama kutusu aracılığıyla proje dosyalarında filtreleme ve arama yapılabilir. Panellerin en altında sol tarafta bulunan buton tüm panelleri göstermeyi ve gizlemeyi sağlar.

Paneller

En sol tarafta ise editörün temel arayüzleri arasında gezinmeyi sağlayan navigasyon butonları mevcuttur. Bu butonları kullanarak arayüz editörü, etiket/kanal editörü ve proje konfigurasyon araçları arasında geçiş yapabilirsiniz. Navigasyon butonlarının en altında proje seçici bulunur. Editör üzerinde aynı anda birden fazla proje açıksa, bu buton kullanılarak projeler arası geçiş yapılabilir.

Navigasyon Butonları

Yeni Proje Oluşturma[değiştir | kaynağı değiştir]

Yeni proje oluşturmak için:

  • Dosya>Yeni Dosya ya da Proje > Mikrodev SCA Projesi seçilir.
Yeni Proje Oluşturma


  • Proje ismi ve nereye kaydedeceği seçilir.
Proje Konumu


  • Veritabanı kullanıcı adı ve şifrenizi girdikten sonra "Bağlantıyı Test Et" butonuna basılarak şifre doğrulaması yapılır.(Eğer PostgreSQL veritabanı, sisteminizde kurulu değilse " PgSQL ‘i indir" bağlantısına tıklayarak ilgili versiyonu indirip kurmanız gerekir)
Veritabanı Seçimi
  • Ekran rengi, varsayılan sayfa boyutu gibi görsel parametreler ayarlanır.
Görünüm Ayarları
  • Sonraki sayfada SVN sürüm kontrol aracı kullanacaksak, bununla ilgili ayarlamalar yapılır.
Versiyon Kontrol
  • "Finish" butonuna basılarak yeni proje oluşturulmuş olur. Yeni oluşturduğunuz proje 2 adet dosyadan oluşur. Bunlardan ilki proje yapılandırma parametrelerinin saklandığı “scapro” uzantılı dosyadır. Bu dosya üzerinde herhangi bir değişiklik yapmanıza genelde ihtiyaç yoktur. Otomatik oluşturulan diğer dosya ise “intro.sca” ismindeki dosyadır. SCADA sisteminde kullanacağınız ana ekranı bu sayfa üzerinde tasarlayabilirsiniz.
Proje Dosyaları

Etiket ve Kanal Editörü[değiştir | kaynağı değiştir]

Kanal ve etiketler, SCADA yazılımının sahadaki cihazlar üzerindeki veriye ulaşabilmesini sağlayan özel tanımlardır. Kanallar, sahadaki cihaz ile haberleşmeyi sağlayacak olan protokol tanımlarını ve bu protokole ait özel ayarları içerir. Etiketler ise bağlantı kurulmuş olan cihaz üzerindeki yazmaçlara ait adres tanımlarından oluşur.

Açılan diyalogda yeni kanalla ilgili gerekli ayarlamalar yapılabilir.

Kanallar[değiştir | kaynağı değiştir]

Sahadaki bir cihaz ile bağlantı tanımlarını içeren kanallar oluşturulabileceği gibi, aynı zamanda makro veya veritabanı sorgusu gibi sanal bağlantıların da tanımlandığı özel kanallar oluşturulabilir.

Yeni bir kanal oluşturmak için “Etiket Kanal Editörü” sekmesi açılarak, herhangi bir kanal üzerine sağ fare butonuna basılır ve açılan menüden “Yeni Kanal” seçilir.

Modbus TCP Protokol Kanalı[değiştir | kaynağı değiştir]

Sahadaki cihazlarla TCP üzerinden modbus protokolü kullanarak haberleşmek için yeni bir Modbus Kanalı oluşturmalısınız.

Yeni kanal oluşturma diyaloğunda “Protokol Tipi” olarak “Modbus TCP” seçin.

Parametreler

Sunucu Adresi: Bağlanmak istediğiniz cihazın IP adresi

Sunucu Portu: Cihazın modbus bağlantı port bilgisi

Yanıt Zaman Aşımı: Herbir modbus sorgusundan sonra Modbus Slave cihazın yanıt vermesi için beklenecek milisaniye cinsinden süredir. Bu süre içerisinde slave cihazdan yanıt gelmezse yeni bir sorgu gönderilir.

Bağlantı Zaman Aşımı: Cihaza bağlanma talebi gönderildikten sonra yeni bir bağlantı denemesi yapılacağı ana kadar beklenecek olan milisaniye cinsinden süredir. Tipik olarak GPRS veya 3G şebekelerinde bu süre TCP ye göre biraz daha uzun olabilir.

Çerçeve Zaman Aşımı: Modbus sorgusuna yanıt geldikten sonra bir sonraki sorgunun yapılması için beklenecek milisaniye cinsinden süredir

Modbus konfigürasyonu ile ilgili detaylı bilgi için şuraya bakınız.

IEC 104 Protokol Kanalı[değiştir | kaynağı değiştir]

Sahadaki cihazlarla TCP üzerinden IEC 104 protokolü kullanarak haberleşmek için yeni bir IEC 104 Kanalı oluşturmalısınız.

SNMP Kanalı[değiştir | kaynağı değiştir]

SNMP cihazlara bağlanmak için kullanılan kanal tipidir. Bu kanal tipinin çalışabilmesi için sisteminizde NetSnmp kütüphanesi kurulu olmalıdır. NetSnmp kütüphanesini buradan indirebilirsiniz

Parametreler

Sunucu Adresi: Bağlanmak istediğiniz cihazın IP adresi

Read Comunity: Cihaz bilgilerine ulaşmak için kullanılacak olan "Read Community" bilgisidir.

Makro Kanalı[değiştir | kaynağı değiştir]

Sanal etiketler oluşturmak ve scriptlerle bu etiketleri değiştirmek için oluşturulacak kanaldır.

Parametreler

Çerçeve Zaman Aşımı: Makronun çalıştırılma sıklığını ifade eden milisaniye cinsinden süredir.

Veritabanı Kanalı[değiştir | kaynağı değiştir]

SCADA veritabanından özel sorgular yapmak için kullanılan kanal tipidir.

Parametreler

Yanıt Zaman Aşımı: Veritabanı sorgusunun çalıştırılma sıklığını ifade eden milisaniye cinsinden süredir.

PLC ve SCADA Projelerini İlişkilendirme[değiştir | kaynağı değiştir]

Geliştirmiş olduğunuz proje büyüdükçe SCADA' da tanımlamış olduğunuz kanalların ait olduğu PLC projeleri ile ilişkilendirilmesi hataları önleme adına önem kazanmaktadır. Bunu sağlamak için kanal menüsünün sağ üst köşesinde bulunan PLC proje yolunu belirlemelisiniz.

PLC Proje Yolu Atama

Bu sayede ilgili kanala ait PLC projesine tek tuşla kolayca erişebilirsiniz.

Etiketler[değiştir | kaynağı değiştir]

"Etiket" sahadan okunan veya sistem tarafından sanal olarak oluşturlan nokta verilerini ifade eder. Etiketler kanalların altında tanımlanır ve içinde bulundukları kanal tipine göre farklı özelliklere sahip olabilirler.


Etiket Ayarları

Sistemde oluşturulan tüm etiketlerin değiştirilebilen ortak özellikleri mevcuttur. Bu özellikler şunlardır:

Etiket[değiştir | kaynağı değiştir]

Kullanımda: Etiket "Kullanımda" olarak işaretlenmezse SCADA sunucu tarafından yok sayılır. Sistemde sadece tanımı bulunur. Etiket Adı: Her etiketin benzersiz bir adı olmalıdır. Etiketi kısaca tanımlayacak anlaşılır kelimeler ve format kullanılmalıdr Etiket ID: Sistem tarafından etikete atanan benzersiz bir sayıdır. SCADA sistemi etiketi tanımlamak için bu ID yi kullanır Tanım: Etiketin ne olduğunu ifade eden bir açıklamadır(Depo seviyesi, Sıcaklık vb..) Birim Adı: Ölçüm değerinin birimi bu alana yazılır(Bar,cm,Celsius vb..) Kanal Adı: Etiketin içinde bulunduğu kanalın adıdır. "Kanalı şuna değiştir" seçeneği kullanılarak etiket faklı bir kanala taşınabilir Anahtar Kelimeler: Raporlama sisteminde etiketi daha kolay seçebilmek için kullanılan kelime gruplarıdır.

Erişim Hakları[değiştir | kaynağı değiştir]

Okuma: Kullanıcıların etiket değerlerini görebilmeleri için sahip olmaları gereken haklardır. Burada ayarlanan haklara sahip olmayan kullanıcılar bu etiket değerini göremezler. Yazma: Kullanıcıların etiket değerlerini değiştirebilmeleri için sahip olmaları gereken haklardır. Burada ayarlanan haklara sahip olmayan kullanıcılar bu etiket değerini değiştiremezler.

Değişken[değiştir | kaynağı değiştir]

Değişken Tipi: Etiketin matematiksel tipidir.

Loglama[değiştir | kaynağı değiştir]

Veritabanına Logla: Bu seçenek aktif edilmezse etiket değeri sistemde loglanmaz ve geçmişe yönelik değerleri görülemez. Ayrıca grafik üzerinde geçmiş değerler de izlenemez. Değişimde Logla: Loglama etiket değeri değiştiği durumda yapılır. Değişimin türü "Yüzde" ya da "Seviye" değişimi türünden olabilir. Yüzde Değişim: Değişim türü olarak "Yüzde Değişim" seçilmişse; etiket mevcut değerinin belirtilen yüzde değeri kadar değişirse loglama yapılır. Değer "0" seçilirse her türlü değişim loglanır. Seviye Değişimi: Değişim türü olarak "Seviye Değişimi" seçilmişse; etiket değeri belirtilen değer kadar değişmişse loglama yapılır. Değer "0" seçilirse her türlü değişim loglanır. Periyodik Olarak Logla : Bu seçenek aktif edilmişse belirtilen zaman petiotlarında etiket sürekli olarak loglanır.

Not: Loglanacak etiketler ve loglama türü, saklanacak veri boyutunun gereksiz artışına engel olmak için dikkatle seçilmelidir. Örnek olarak;

  • Geriye dönük değerlerine ihtiyaç duymayacağınız etiketler kesinlikle loglanmamalıdır.
  • Analog değişkenler için seviye veya yüzde değişim seçilmişse, veri değişim paternine uygun bir yüzde ya da seviye seçilmelidir.
  • Dijital değerler için peryodik loglama yerine değişimde loglama yapılmalıdır

Alarmlar[değiştir | kaynağı değiştir]

Alarmlar

Sayfa Özellikleri Paneli[değiştir | kaynağı değiştir]

Katmanlar Paneli[değiştir | kaynağı değiştir]

Katmanlar paneli üzerinde yeni katman oluşturabilir veya silebilirsiniz. Oluşturduğunuz katmanlar üzerinde bileşenler oluşturarak, sayfa üzerinde hiyerarşik bir düzen kurabilirsiniz. Katmanları gizleyip/göstererek karmaşık tasarımları daha kolay biraraya getirebilirsiniz. Katmanların sağladığı bir diğer fayda da farklı ölçek(zoom) seviyelerinde katmanların görünürlüğünün değiştirilebilmesidir.

Katmanları Gizleme/Gösterme[değiştir | kaynağı değiştir]

Eklemiş olduğunuz katmanları, fare sağ tuş menüsü üzerinde bulunan "Katmanı Gizle/Göster" seçeneğini kullanarak gizleyip/gösterebilirsiniz.

Katman Özellikleri

Katmandaki Bileşenlerin Sıralamasını Değiştirme[değiştir | kaynağı değiştir]

Eklemiş olduğunuz katmanların sıralamalarını, fare sağ tuş menüsü üzerinde bulunan "Katman Bileşenlerini Öne Getir" ya da "Katman Bileşenlerini Arkaya At" seçeneklerini kullanarak değiştirebilirsiniz.

Katmanları Ölçek Seviyesine Göre Gizleme/Gösterme[değiştir | kaynağı değiştir]

Ekranın ölçek seviyesine göre sayfada tanımlanmış olan katmanları gizleyip gösterebilirsiniz. Bu sayede ölçek seviyesi arttığında daha detay bilgi içeren bileşenleri gösterebilirken, ölçek seviyesi arttığında az sayıda bileşeni göstererek tasarımdaki karmaşıklığı azaltıp, kullanımı kolaylaştırabilirsiniz. Bunun için öncelikle "Katmanlar Paneli" nde "Katman Özellikleri" ni seçin


Açılan dialogda ölçek seviyesi parametrelerini gösteren iki alan mevcuttur.

Katman Özellikleri2

Katman burada girilecek olan iki ölçek değeri arasında görünür olacaktır. Değerlerden birini "-1" olarak tanımlarsanız katman bu yönde ölçekten bağımsız olarak sürekli görünür olacaktır. Örnek olarak "300" ve "-1" değerleri düşünüldüğünde, bu şu manaya gelecektir: "Ölçek '3' değerinden daha büyükse katmanı görünür yap"


Ölçek '3' den küçük:

Ölçek Düşük


Ölçek '3' den yüksek:

Ölçek Düşük

Resimde de görüldüğü gibi ölçek değeri '3' ün üstüne çıktığında, butonların bulunduğu katman görünür hale gelmiştir.

Nesne Özellikleri Paneli[değiştir | kaynağı değiştir]

Etiketler Paneli[değiştir | kaynağı değiştir]

Diğer Özellikler Paneli[değiştir | kaynağı değiştir]

E-posta Sunucu Ayarları[değiştir | kaynağı değiştir]

Kullanıcı yöneticisinden e-posta gönderimi aktif olarak işaretlenmiş kullanıcılara, alarm durumlarında e-posta gönderimi yapılabilir. Bunun için sunucuda e-posta konfigurasyon ayarlarının yapılması gerekmektedir. Bunun yanında kullanılacak olan smtp sunucusunun "az güvenli uygulama erişimine" açık olması gerekmektedir. E-posta sunucu ayarlarının yapılabileceği "ServerEngine.ini" konfigurasyon dosyası şu klasördedir:

C:\Users\<kullanıcı adı>\AppData\Roaming\Mikrodev\ ScadaServer\<proje adı>\ServerEngine.ini

Bu dosyada [SMTP] seçeneğinin altında şu değişkenler doğru şekilde ayarlanmalıdır:

[SMTP]

SMTP_user=<e-posta kullanıcı adı>

SMTP_pwd=<e-posta şifresi>

SMTP_host=<smtp sunucu adresi>

SMTP_port=<smtp sunucu portu>

SMTP_mailDelay=<alarm durumundan sonra e-postanın gönderilmesi için beklenecek süre (saniye olarak)>

Yaptığınız ayarları test etmek için şu linkteki programcığı kullanabilirsiniz.

SCADA Görsel Bileşenleri[değiştir | kaynağı değiştir]

Mikrodev SCADA , izlenen verilerin görselleştirilmesi için farklı tiplerde bileşenler sunar. Bunlar; temel bileşenler, zamanlayıcı, grafik, veri tabanı sorgu ve metin bileşenleridir.

SCADA Bileşenleri


Temel Bileşenler[değiştir | kaynağı değiştir]

Temel bileşenler Editörün solundaki panelde "SCADA Bileşenleri" bölmesi içinde bulunmaktadır.

“Bileşen Yöneticisi” kullanılarak buradaki bileşenlere kullanıcının tanımlamış olduğu farklı nesneler de eklenebilir. Mevcut sayfaya bileşen eklemek için paneldeki bileşenlerden birine sol fare tuşu ile bastıktan sonra, sahnede istenen pozisyona sol fare tuşu ile tekrar basılır ve bileşen eklenmiş olur.

Boyutlandırma

Eklenen bileşenin boyutlarını değiştirmek için bileşenin sol alt köşesindeki üçgen ikonunu fare ile hareket ettirebilirsiniz. Bileşene ait gelişmiş özellikleri değiştirmek için “Bileşen Özellikleri Paneli” kullanılır.

Zamanlayıcı Bileşeni[değiştir | kaynağı değiştir]

Mikrodiagram yazılımda PLC projesine eklemiş olduğunuz “Zamanlayıcı Blokları” nın kontrolünü “Zamanlayıcı” bileşeni üzerinden yapabilirsiniz. Etiket/Kanal Editöründe tanımlamış olduğunuz “Zamanlayıcı Etiketleri” ni zamanlayıcı bileşenine ekleyerek, istemci üzerinden kullanıcıların zamanlama ayarlarını değiştirebilmeleri sağlanır.

9 Zamanlayıcı Bileşeni

Grafik Bileşeni[değiştir | kaynağı değiştir]

Grafik bileşeni kullanılarak, istediğiniz etikete ait verileri grafiksel olarak izleyebilirsiniz. Grafik nesnesi grafikleri çizgi grafiği şeklinde gösterir. Grafik ayarları penceresinde grafiğin görünümü, davranışı ve gösterilecek etiketlere ait parametreler ayarlanabilir.

Grafik Bileşeni

Veritabanı Sorgu Bileşeni[değiştir | kaynağı değiştir]

Bu bileşen veritabanından bazı özel sorguların alınarak istemci üzerinde gösterilmesini sağlar. Veritabanı sorgu ayarları penceresinde, sorgulanacak etiket, sorgu tipi, aralığı, güncelleme sıklığı ve bileşenin göeünümüyle ilgili parametreler ayarlanabilir.

Veritabanı Sorgu Bileşeni

Metin Bileşeni[değiştir | kaynağı değiştir]

Metin bileşeni, farklı font, renk ve biçimde yazıları ekranda göstermek için kullanılır. Metin bileşeni üzerinde herhangi bir dinamik içerik gösterilmez. Sabit metinler için kullanılır. Metnin format ayarlarını araç çubuğundaki "Format" sekmesinden değiştirebilirsiniz.

Metin Bileşeni

Bileşen Parametreleri[değiştir | kaynağı değiştir]

Bileşenlere ait çok sayıda parametre "Bileşen Parametreleri" panelinden ayarlanabilir.

Özellikler Sekmesi

Bileşen Parametreleri - Özellikler

Nesne Adı: Bileşenleri birbirinden ayırmak için kullanıcı tarafından atanan isim bu alana girilir.

Geometri: Bileşenin ekrandaki konumu, boyutu ve rotasyon ayarları tam sayı değerler olarak girilir.

Sabitler

  • Yazı X Ofseti: "Yazı Etiketi" tanımlanmışsa ve "Yazı İçeriği" girilmişse, bu parametre gösterilecek olan metin için yatay bir ofset tanımlar.
  • Yazı Y Ofseti: "Yazı Etiketi" tanımlanmışsa ve "Yazı İçeriği" girilmişse, bu parametre gösterilecek olan metin için dikey bir ofset tanımlar.
  • Yazı İçeriği: "Yazı Etiketi" tanımlanmışsa, buraya girilmiş olan "formatlanmış" metin, bileşen üzerine yazdırılır. Girilecek metin "printf metin formatı"nda olmalıdır. Formatlama için aşağıdaki örnekler kullanılabilir:
   Tamsayılar:         %d     =>"1977"
   Öne boşluk ekleme:       %10d     =>"       1977"
   Öne sıfır ekleme:    %010d    =>"0000001977"
   Float sayılar:         %4.2f    =>"3.14"


  • Yazı Stilsayfası: Gösterilecek olan "Yazı İçeriği" için stilsayfası tanımlayarak, yazı fontu, boyutu ve rengi gibi görünüm ayarlarını yapabilirsiniz. Burada bazı örnekler bulabilirsiniz.
  • Sayfaya Git: "Olay Aksiyonu" parametresi "SAYFAYAGİT" olarak tanımlanmışsa, burada tanımlanmış olan sayfa bileşen üzerine basıldığında istemci ekranında açılır.
  • Metin Genişliği: Bileşen üzerinde gösterilecek olan metnin maksimum genişlik değeridir.

Olaylar

  • Hedef Olay Etiketi: "Olay Aksiyonu" nun hedefi olan etiketi tanımlar
  • Olay Tipi : Olayın hangi durumda tetikleneceğini belirleyen parametredir.
    • FareTuşunaBasıldı: Sol fare tuşuna basılma olayı
    • FareTuşuBırakıldı: Sol fare tuşu bırakılma olayı
    • TuşBasıldı: Klavye tuşu basma olayı
  • Olay Aksiyonu: "Olay Tipi" tetiklendiğinde çalıştırılacak olan fonksiyon seçilir
    • ATA  : "Hedef Olay Etiketi" nin değerini "1" yapar.
    • TEMİZLE  : "Hedef Olay Etiketi" nin değerini "0" yapar.
    • DEĞİŞTİR  : "Hedef Olay Etiketi" nin değerini "1" ise "0", "0" ise "1" yapar.
    • DEĞERİYÜKLE: Bu fonksiyon seçilirse, kullanıcılar istemci yazılımda bu bileşene fare ile sağ tıklayarak “Hedef OlayEtiketi” nin değerini değiştirebilecekleri bir diyalog sayfası çıkar.
    • SONRAKİSAYFA
    • ÖNCEKİSAYFA
    • SAYFAYAGİT : "Sayfaya Git" de seçilmiş olan sayfa ekranda açılır.


Etiketler Sekmesi

Bu panelden seçilen etiketlerden okunan değerler, karşısındaki parametreyi sahadan okunan değerlere göre devamlı olarak günceller.

Aynı zamanda burada tanımlanan etiketler makrolarda da kullanılabilir. Her etiket için öntanımlı "i, o, s, w" değerleri vardır. (i1,i2.. o1,o2.. gibi). Etiketlerin öntanımlı değişken isimlerini fare ile üzerine gelerek görebilirsiniz.

Bileşen Parametreleri - Etiketler


Özellik Etiketleri

  • Resim Index Etiketi: Bileşenin anlık olarak gösterilecek resim indeksini gösterir. Hangi indekste hangi resmin bulunacağı "Bileşen Yöneticisi" nden değiştirilebilir veya "Diğer Sekmesi"nde "resimler" in altında görülebilir.
  • Yazı Etiketi :Burada seçilen etiketin değeri, "Yazı İçeriği" nde belirlenen formata göre bileşen üzerinde gösterilir.
  • X Konumu : Bileşenin ekrandaki yatay pozisyon koordinatı bu parametreden alınır. Sayfanın sol üst köşesi (0,0) koordinatıdır. Sağa doğru gidildikçe X değeri artar.
  • Y Konumu : Bileşenin ekrandaki dikey pozisyon koordinatı bu parametreden alınır. Sayfanın sol üst köşesi (0,0) koordinatıdır. Aşağı doğru gidildikçe Y değeri artar.
  • Genişlik : Bileşenin genişlik değeri bu etiketten okunur.
  • Yükseklik : Bileşenin yükseklik değeri bu etiketten okunur.
  • Döndürme Açısı : Bileşenin X ekseni le yaptığı rotasyon açısıdır. Derece cinsinden değer alır.
  • Metin rengi : Bileşen üzerinde gösterilecek olan metnin rengi bu parametreden alınır.*
  • Maske rengi : Bileşen üzerinde uygulanacak olan maskenin rengi bu parametreden alınır.*
  • *#112233 şeklinde tanımlanan RGB renk değerinin "112233" şeklindeki hex değerinin, tamsayı karşılığı şeklinde değer alınır .Örnek hex renk değerlerini buradan görebilirsiniz. Seçtiğiniz renk değerini tamsayıya çevirmek için buraya bakabilirsiniz.
  • Maske Saydamlığı: Gösterilecek olan maskenin saydamlık değeri için 0-255 arası bir değer bu etiketten alınır.
  • Özel Etiketler: Burada seçeceğiniz 7 adet etiket makrolarda kullanılabilir.

Diğer Sekmesi

Bileşen Parametreleri - Diğer
  • Limitler: Kullanıcıların istemci yazılımı üzerinden “Hedef Olay Etiketi” değerini değiştirebilecekleri maksimum ve minimum değerler buradaki parametreler kullanılarak ayarlanır.
  • İpucu: Kullanıcıların istemci yazılımında fareyi bileşen üzerine getirdiklerinde gösterilecek içeriği ayarlar.
  • Makro: Bileşen için yazılacak makra scripti bu kutuya yazılır. Makrolar hakkında ayrıntılı bilgi için ilgili bölüme bakınız.
  • Webbağlantısı: Eğer bu alanda bir web safyası linki tanımlanırsa, bileşene fare ile sağ tıklayarak açılan menuden, ilgili sayfaya ulaşılabilecek bir menu girdisi oluşturulur.
  • Resimler: Bu bileşen içerisinde tanımlı resimler ve indeks numaraları bu alanda gösterilir.

Kullanıcı Yöneticisi[değiştir | kaynağı değiştir]

Yeni kullanıcı ekleme ve kullanıcı özelliklerini değiştirme işlemleri "Kullanıcı Yöneticisi" ile gerçekleştirilir.

Bileşen Yöneticisi[değiştir | kaynağı değiştir]

Yeni görsel bileşenler ve animasyonlar eklemek için "comx" bileşen dosyaları oluşturmanız gerekmektedir. Bunun için "Bileşen Yöneticisi" ni kullanabilirsiniz.

•MikroscadaEditor Araçlar menusu üzerinden başlatıldığında, ilgili projeye ait bileşen klasörü içerisindeki bileşenler gösterilir.

Bileşen Yöneticisi1

• Yeni Bileşen eklemek içim "Yeni Bileşen Ekle" seçilerek, eklenmek istenilen görsel veya görseller seçilir. Görseller (.png,.jipeg,.gif,.svg) formatlarında olabilir.

Bileşen Yöneticisi 2

•Component Name =Bileşenin ismi girilir. •Componet Category =Bileşenin olmasını istediğimiz katagori ismi yazılır.Birden fazla bileşenin aynı katagori altında olması istenirse aynı işlemler tekrarlanır, önemli olan kategori isminin aynı olmasıdır aksi taktirde bileşen farklı bir katagoriye eklenir. •Use First image's size =Bu komut eklenen nesnenin orjinal boyutlarında ayarlanması için kullanılır. Verilere göre değişmesini istediğimiz nesneleri eklerken ilk sıradaki resmin boyutlarına göre diğerlerinide boyutlandırır.

Sunucu Yazılımı[değiştir | kaynağı değiştir]

Sunucu yazılımının çalıştırılabilmesi için bir proje ile ilişkilendirilmesi gerekir. Editör menüsünden çalıştırıldığında, halihazırda açık olan proje sunucu tarafından kullanılır. Sunucuyu editörden bağımsız olarak çalıştırmak için “Editör > Araçlar >Sunucu Dosyalarını Oluştur” seçilerek bir klasör belirtilir ve sunucu dosyaları bu klasöre kopyalanır. “ServerEngine” programcığı sunucuyu başlatmak için kullanılır. “ServerEngine” programcığı, varsayılan davranış olarak kendisiyle aynı klasörde “Project” isminde bir klasör arar.

“Project” klasörü editör tarafından oluşturulan özel dosyalar içerir. Bunların başlıcaları; “MikrodevScada.ini” ,”Project.zip”, “.sca uzantılı proje sayfaları” ve bileşen dosyalarıdır. Sunucu hangi veritabanına bağlanacağını ve kayıtları tutacağı yer gibi bilgileri “MikrodevScada.ini” dosyasında okur.

SCADA sunucu ilk kez başlatıldığında, kullanıcı tarafından veritabanı bağlantı bilgilerinin girilmesi istenebilir. Sunucu farklı klasördeki bir projeyi de ağaşıdaki komut satırı parametrelerini kullarak açabilir.

“ServerEngine –dir “C:\Users\yg\Desktop\server\projectname“ ”

-dir : Proje klasörü

Sunucu Ana Ekranı

Sunucunun ana ekranında genel sistem loglarının izlenebileceği bir konsol bulunur. Bu konsol üzerinde sunucu ile ilgili önemli değişimler gösterilir. Daha detaylı sunucu logları ayrı bir dosyada kaydedilir. “Başlat” butonuna basıldığında sunucu saha cihazlarıyla bağlantı kurar. Bağlantı kurulduktan sonra sunucu istemcilerin bağlanabileceği bir port açar ve gelen bağlantıları bekler. Sunucu sahadan veri okumaya başladığında, proje ayarlarında belirtildiği şekilde bu verileri veritabanı sunucusuna göndererek kaydeder. Etiket izleme ekranında sahadan okunan verilerin anlık değerleri izlenebilir.


Sunucu Etiket İzleme Ekranı'


Etiket izleme ekranındaki anlık değerler üzerinde etiketId, etiket adı, kanal adı, cihaz adresi gibi parametrelere göre filtreleme yapılabilir.

“Değer” alanında gösterilen sayısal verinin yanında “dced” şeklinde bir metin bulunuyorsa, bu durum  cihaz ile SCADA sunucu arasında bir bağlantı problemi olduğunu gösterir

Sürücü izleme ekranında çalışan protokol sürücüleriyle ilgili bilgiler verilir. Bu konsoldan cihaz bağlantı problemleriyle ilgili bilgiler elde edilebilir.

Alarm ekranı ise, sistemde oluşmuş olan alarmların geçmişi ve mevcut alarmların gözlemlenebilmesini sağlar.

Sunucuyu Otomatik Başlatma[değiştir | kaynağı değiştir]

Windows Platformu[değiştir | kaynağı değiştir]

Sunucuyu otomatik başlatmak için şu adımları takip ediniz ("TestProjesi" isimli örnek bir proje icin ): 

  • MikroscadaEditor' ün kurulum klasörü içindeki "ServerEngine.exe" programcığı için masaüstüne bir kısayol oluşturun.
Kısayol Oluşturma
  • Oluşturulan kısayola sağ tıklayıp "Özellikler"i  seçin.
  • "Target" yazan alanı şu şekilde değiştirin (Dosya yolunu kendi sisteminize göre değiştirin): 

"C:\Program Files (x86)\MikroscadaEditor\bin\ServerEngine.exe" -dir "C:\Users\<User Name>\TestProjesi" -start 

  • Sonra bu kısayolu "C:\Users\<User Name>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup" altına kopyalayın. Artık kullanıcı sisteme giriş yapınca sunucu otomatik olarak başlayacaktır.
  • OperatorClient kısayolunu da "C:\Users\<User Name>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup" altına kopyalayarak açılışta otomatik başlaması sağlanabilir.

Linux Platformu[değiştir | kaynağı değiştir]

Sunucu Runtime Oluşturma[değiştir | kaynağı değiştir]

Geliştirilen SCADA projesini farklı bir bilgisayarda MikroscadaEditor kurmadan da çalıştırabilirsiniz. Bunun için "Araçlar" menüsünden "Sunucu Dosyalarını Oluştur" u seçerek, proje ve sunucunun çalışması için gerek dosyaları bir klasör içerisinde toplayabilirsiniz. Bu klasörü taşıyarak, projenizi farklı sunucu makineleri üzerinde çalıştırmanız mümkündür.

İstemci Yazılımı[değiştir | kaynağı değiştir]

İstemci yazılımı; uç kullanıcıların SCADA sunucusuna internet ya da intranet üzerinden bağlanarak, hazırlanan projeyi izlemelerini ve kontrol edebilmelerini sağlar.

İstemci Giriş Ekranı


SCADA sunucuya bağlanabilmek için kullanıcı, şifre, sunucu adresi ve portu bilgilerini istemci yazılımına girmeniz gerekir. Yeni bir kullanıcı oluşturmak için "Kullanıcı Yöneticisi" ni kullanmanız gerekir. Bu bilgiler doğru bir şekilde girildiğinde sunucu ile istemci yazılımı arasında şifrelenmiş bir bağlantı oluşturulur ve sunucudan gönderilen proje giriş ekranı istemcide gösterilir.

İstemci ekranının sol tarafında yer alan “sayfa seçici” de, editörde “SCADA Sekmesi” olarak tanımlanan sayfalar için kısayollar gösterilir. Burada gösterilen kısayolların görünümü ve sırası editör üzerinde ayarlanabilir. Bu kısayollar yanında alarm paneli ve web görünüm paneli kısayolları bulunur.

İstemci Ekranı

Erişim Yetkileri

İstemci üzerinde gösterilen içerik; kullanıcının, sayfaların ve tanımlı etiketlerin erişim yetkilerine bağlı olarak değişiklik gösterebilir. Kullanıcının erişim yetkisi olmayan sayfalar “sayfa seçici” de gösterilmez ya da bu sayfalara doğru olan bağlantılar çalışmaz. Eğer sayfadaki bir görsel öğe, kullanıcının erişim yetkisi olmayan bir etiket içeriyorsa kullanıcının bu öğeyi izlemesi veya kontrolü engellenir.

Raporlama Yazılımı[değiştir | kaynağı değiştir]

SCADA yazılımının loglamış olduğu trend verilerini görmek ve analiz etmek için Raporlayıcı 'yı kullanabilirsiniz. Raporlayıcı üç temel log verisi ile ilgili raporlama yapmanızı sağlar. Bunlar etiket logları, alarm logları ve olay loglarıdır.

Gelişmiş Ayarlar[değiştir | kaynağı değiştir]

log_server.txt:

Windows sistemlerde şu klasör içinde bulunur:

C:\Users\<username>\AppData\Roaming\Mikrodev\ScadaServer\<proje adı>

Sunucuya ait detaylı logların bulunduğu dosyadır

log_serverstarter.txt :

Sunucu izleyici yazılımına ait logların bulunduğu dosyadır

OperatorClient.ini :

ServerEngine.ini:

Windows sistemlerde şu klasör içinde bulunur:

C:\Users\<kullanıcı adı>\AppData\Mikrodev\ScadaServer\<proje adı>

[Login]> ServerAdr: Veritabanı adresi

[Login]> DbName: Veritabanı adı

[Login]> DbUserName: Veritabanı kullanıcı adı

[Login]> DbPassword: Veritabanı şifresi

[Connection] > Port: Varsayılan sunucu portu 560 dır. Farklı bir port bu parametre değiştirilerek seçilebilir.

[Logging] > IsLogging: Veri loglama aktif/pasif yapılabilir(true/false)

[Logging] > IsLoggingDısconnections: Bağlantı kopmalarının loglanıp loglanmayacağı seçilebilir

[REDUNDANCY]> ServerMode: Yedekli çalışma modunu belirler. Bu değer PRIMARY ya da BACKUP olabilir. Bu mod backup olarak ayarlandığında, sunucu PRIMARY sunucu ile haberleşerek redundant bir yaı oluştururlar.

[REDUNDANCY]> PrimaryIP: BACKUP moddaki sunucunun bağlanacağı PRIMARY sunucu IP adresi bu alana yazılır.

[REDUNDANCY]> PrimaryPORT: BACKUP moddaki sunucunun bağlanacağı PRIMARY sunucunun port numarasıbu alana yazılır.

[REDUNDANCY]> Timeout: PRIMARY sunucunun ne kadar sürelik bir devredışı kalma durumunda BACKUP sunucunun aktif olacağını belirleyen saniye cinsinden değerdir.

Makro Kılavuzu[değiştir | kaynağı değiştir]

Mikrosacada farklı tiplerde makrolar desteklemektedir. Bu makroların bir kısmı sunucu tarafında çalışırken, bir kısmı ise istemci tarafında çalışabilmektedir.

Etiket/Kanal Editöründe tanımladığımız “makro etiketleri” sunucu tarafında çalışır. Ve sanal bir etiket işlevini görürür. Bu makrolar belirlenen periodlarla sunucuda sürekli olarak çalışırlar.

Editör üzerinde ise her bir nesne için ayrı makrolar yazmak mümkündür. Bu makrolar ise o nesneye ait gösterim ve davranışları etkiler ve sadece ilgili nesneyi kullanıcı izlerken çalıştırılırlar.


Sunucu Makro Etiketleri[değiştir | kaynağı değiştir]

Makrolar bir seferde iki işlem elemanı alabilir ve satır satır yazılırlar.

Örnek:

[ v0 = $1234 * 2]

Makro içerisine eklenebilecek operandlar şunlardır:

200 farklı değişken(vo, v1, …., v199)

Etiket değerleri (“$1234” formatında)

Sabit değerler (“234,12” gibi sabit ondalık değerler eklenebilir)

[ v0 = $1234 * 2]

v0 : “ = ” in solundaki elemana işlemin sonucu yazılır

* : İşlem tipi olarak “+ , - , * , / , % , & , |, ^ , > , < , e ,b , k , n , ?“ gibi operatörler kullanılabilir. Burada:

e: eşitlik kontrolü. Operandlar birbirine eşitse sonuç “1” döner, değilse “0” döner.

n: eşit değil kontrolü. Operandlar birbirine eşit değilse sonuç “1” döner, değilse “0” döner.

b: büyüktür kontrolü. İlk operand ikinciden büyükse sonuç “1” döner, değilse “0” döner.

k: küçüktür kontrolü. İlk operand ikinciden küçük ise sonuç “1” döner, değilse “0” döner.

?: Bu özel bir operanddır.

[ v0 = 1234 ? 0]  : 1234 nolu etiketin “RX Count” değerini döndürür (Okuma sayaç değeri)

[ v0 = 1234 ? 1]  : 1234 nolu etiketin bulunduğu cihaz ile haberleşme olup olmadığını kontrol eder

[ v0 = 1234 ? 2]  : 1234 nolu etiketin “Read Time” değerini döndürür (Sahadan en son veri okunan zaman)

[ v0 = 1234 ? 3]  : 1234 nolu etiketin içerisinde geçerli bir değer olup olmadığını kontrol eder.(Genelde SCADA sunucu ilk başladığında etiket içerisine geçerli bir değer yazılması gecikebilir ya da cihazla bağlantı kurulamazsa etikete geçerli bir değer hiçbir zaman yazılmayabilir-)

Dikkat: Burada etiket id (örnekteki 1234) başında “$” olmadan sabit bir değer olarak makroya girilmelidir


Koşul kontrolü:

Aşağıdaki örnekte “v0” değişkeninin 1’e eşit olup olmadığı kontrol ediliyor. Eğer “v0” 1’ e eşitse makro bir alt satırdaki komutu işler.(v1 değerini 555 yapar) Eğer 1’e eşit değilse “IF” satırının ikinci parametresi( “2” ) kadar satır aşağı inilir. Bu örnekte “v0” 1’e eşit değilse makro 2 satır aşağı inecek , yani dönüş değeri ([E] ) satırına gidecek ve bitirilecektir.

[ IF , v0 , 2]

[ v1 = 555]

[ E ]


Diğer bir koşul kontrol operandı “NI” (NOT IF) dir. Bu da “IF” in tam tersi olarak 0’a eşitlik kontrolü yapar.

Aşağıdaki örnekte “v0” değişkeninin 0’a eşit olup olmadığı kontrol ediliyor. Eğer “v0” 0’ a eşitse makro bir alt satırdaki komutu işler.(v1 değerini 555 yapar) Eğer 0’a eşit değilse “NI” satırının ikinci parametresi( “2” ) kadar satır aşağı inilir. Bu örnekte “v0” 0’a eşit değilse makro 2 satır aşağı inecek , yani dönüş değeri ([E] ) satırına gidecek ve bitirilecektir.

[ NI , v0 , 2]

[ v1 = 555]

[ E ]




Makroların doğru çalışabilmesi için mutlaka dönüş ([E] return) eklenmelidir

İstemci Makroları[değiştir | kaynağı değiştir]

İstemci Makrosu:

Bu makro “sunucu makro” ları ile aynı formatta yazılır. Ancak bu makrolar içinde sadece o nesnede tanımlı etiketler kullanılabilir

Nesnelerin etiket sekmesinde tanımlanan etiketler şu şekilde kullanılır:

Her etiket için öntanımlı "i, o, s, w" değerleri vardır.

i (in) : Etiketin sahadan okunan ham değeri

o (out):Etiketin makro işlemlerinden geçirildikten sonra ekranda gösterilmek istenen değer

s (set):Etiket için kullanıcı tarafından set edilmek istenen değer

w(write): Kullanıcının set etmek istediği değerin makro işlemlerinden geçirildikten sonra sahadaki cihaza yazılmak istenen değer

i ---Makro---->o , s---Makro---->w

Herhangi bir makro işlemi yoksa i o'ya eşittir, s w'ya eşittir.


Tooltip Makrosu:

${ID}  : Etiketin anlık değerini döndürür. ID, etiketin sistemde tanımlı olana etiket id sidir.

Örnek:

Basınç değeri ${4004} bardır : Basınç değeri 5 bardır


#{…..} : Parantezin içinde yazılan aritmetik işlemi gerçekleştirir.

Örnek:

Geçen zaman #{ ${1150} / 3600 } saat veya #{ ${1150} / 60 } dakikadır : Geçen zaman 5 saat veya 300 dakikadır :

Çok Kullanıcılı Çalışma[değiştir | kaynağı değiştir]

Birden çok kullanıcının aynı proje üzerinde çalışabilmesi de mümkündür. Mikroscada projesi daha önce anlatıldığı gibi 2 temel bileşenden oluşur. Proje dosyaları ve veritabanı. Proje dosyalarının faklı kullanıcılar arasında senkronlanabilmesi için bir versiyon kontrol uygulaması(SVN, Clearcase, Git... gibi) na ihtiyaç vardır. Proje veritabanı ise, merkezi bir sunucu üzerinde tutulur ve kullanıcılar projelerini bu veritabanını kullanacak şekilde konfigüre ederlerse, senkronizasyon sağlanır.

SVN ile Senkronizasyon[değiştir | kaynağı değiştir]

Proje dosyalarını farklı bilgisayarlarda senkron olarak saklayabilmek, çakışmaları önlemek ve geçmişe yönelik proje versiyonlarını yedeklemek için SVN gibi bir versiyon kontrol aracı kullanılabilir. Mikroscada entegre olarak SVN ile uyumludur.

PgSQL Veritabanı Uzak Bağlantı[değiştir | kaynağı değiştir]

PgSQL veritabanı kurulduğunda güvenlik önlemi olarak ağdan erişime izin vermez, sadece localhost üzerinden gelen bağlantılara izin verir. Aynı ağdaki kullanıcıların veritabanına erişimini sağlamak için aşağıdaki adımlar izlenmelidir:

1) PgSQL portu(5432) için firewall a bir istisna ekleyin

2) pg_hba.conf dosyasına aşağıdaki satırı ekleyin:

  host all all 0.0.0.0/0 md5

3) postgresql.conf dosyasına aşağıdaki satırı ekleyin:

  listen_addresses='*'


Paralel Yedekli Çalışma Modu[değiştir | kaynağı değiştir]

MikrodevSCADA yazılımı birden fazla bilgisayardan oluşan bir sunucu kümesi üzerinde "Paralel Yedekli Mod" da çalışabilir. Bu sayede sunucu duruş süreleri en aza indirilebilir. Yedekli modun çalışacağı sunucular aynı yerel ağ üzerinde bulunmalıdır.

Kurulum Aşamaları[değiştir | kaynağı değiştir]

  • MikroSCADA bu modda çalışırken, her 2 sunucu da(PRIMARY, BACKUP) ağ üzerinden proje veritabanına ulaşabilir olmalıdır.
  • Aynı zamanda sunucu bilgisayarlarında proje dosyaları bulunmalı ve bunlar güncel(birbiri ile aynı) olmalıdır. Bu senkronizasyonu sağlamak için SVN gibi bir versiyon kontrol aracı kullanılabilir ya da dosyalar elle taşınabilir.
  • Sonraki aşamada birincil sunucu(PRIMARY) ve yedek sunucu(BACKUP) üzerindeki ScadaServer.ini dosyalarında şu konfigürasyon ayarlarının yapılmış olması gerekmektedir:

Birincil sunucu(PRIMARY):

[REDUNDANCY]
ServerMode=PRIMARY
PrimaryIP=192.168.2.201
PrimaryPORT=51314
Timeout=60
size=0

Yedek sunucu(BACKUP):

[REDUNDANCY]
ServerMode=BACKUP
PrimaryIP=192.168.2.201
PrimaryPORT=51314
Timeout=60
size=0

ServerMode: Yedekli çalışma modunu belirler. Bu değer PRIMARY ya da BACKUP olabilir. Bu mod BACKUP olarak ayarlandığında, sunucu PRIMARY sunucu ile haberleşerek redundant bir yapı oluştururlar. PrimaryIP: BACKUP moddaki sunucunun bağlanacağı PRIMARY sunucu IP adresi bu alana yazılır. PrimaryPORT: BACKUP moddaki sunucunun bağlanacağı PRIMARY sunucunun port numarasıbu alana yazılır. Timeout: PRIMARY sunucunun ne kadar sürelik bir devredışı kalma durumunda BACKUP sunucunun aktif olacağını belirleyen saniye cinsinden değerdir.

Örnekte birincil sunucu(PRIMARY) nun IP adresi "192.168.2.201" şeklinde sabit bir IP dir. Kurulacak sistemdeki birincil sunucunun IP adresi bu şekilde bir statik IP olmalıdır, DHCP sunucusundan IP alınmamalıdır. PrimaryPORT' ta ayarlanan port numarası güvenlik isterlerine göre farklı ayarlanabilir. Bu durumda her 2 konfigürasyon dosyasında da değişiklik yapılarak doğru port numarası girilmelidir.

Konfigürasyon işlemleri tamamlandıktan sonra önce birincil sonra yedek sunucular başlatılır. Bu andan itibaren yedek sunucu, birincil sunucuyu izleyerek, bir kapanma durumunda devreye girer ve çalışmaya başlar. Birincil sunucu tekrar devreye girdiğinde yedek sunucu tekrar izleme moduna geçerek kendini durduracaktır

Ekler[değiştir | kaynağı değiştir]